Student Services Outage
Incident Report for UMass Shared Services
Resolved
Student services have been restored. We will continue to closely monitor. We apologize for the inconvenience.
Posted about 2 months ago. Feb 22, 2019 - 22:21 EST
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Feb 22, 2019 - 21:22 EST
Investigating
Multiple student systems are currently unavailable. We are actively investigating the issue. An update will be provided as soon as the issue is resolved.
Posted about 2 months ago. Feb 22, 2019 - 20:41 EST
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, Parent Access).