Office 365 Degraded Performance
Incident Report for UMass Shared Services
Resolved
Service now available. Microsoft has resolved the intermittent delay issues with OneDrive and SharePoint content.
Posted 5 months ago. Oct 18, 2018 - 07:43 EDT
Investigating
Performance impacted. Actively working as an issue.
Users may experience intermittent delays or navigation errors when accessing SharePoint sites or OneDrive content. Microsoft is investigating.
Posted 5 months ago. Oct 17, 2018 - 15:49 EDT
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).