Student Services Parent Partial Outage
Incident Report for UMass Shared Services
Resolved
Access to student services is restored. We will continue to closely monitor. We apologize for the inconvenience.
Posted about 2 months ago. Feb 23, 2019 - 15:53 EST
Investigating
Multiple student systems were intermittently unavailable between 2:15pm - 2:35pm . We are actively working to restore full access to Student Services Parent. An update will be provided as soon as the issue is resolved.
Posted about 2 months ago. Feb 23, 2019 - 14:46 EST
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, Parent Access, ID Email Lookup, myUMB Applicant Portal).