HR Direct Major Outage
Incident Report for UMass Shared Services
Resolved
HR Direct production is available. We will continue to closely monitor.

We apologize for any inconvenience.
Posted 5 months ago. Nov 26, 2018 - 09:11 EST
Investigating
HR Direct production is unavailable. People may experience spinning at log in. We are actively investigating.
Posted 5 months ago. Nov 26, 2018 - 08:31 EST
This incident affected: Human Resources (* HR Direct).