Summit-Finance - Partical Outage
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted about 1 month ago. Oct 12, 2018 - 08:04 EDT
Investigating
Summit Finance Batch is running late.
Posted about 1 month ago. Oct 12, 2018 - 07:24 EDT
This incident affected: Summit (Summit - Finance).