Office 365 - Degraded Performance
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 26, 2019 - 08:40 EST
Investigating
Performance impacted. Actively working as an issue.
Posted about 2 months ago. Feb 25, 2019 - 09:37 EST
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).