Summit - Partial Outage
Incident Report for UMass Shared Services
Resolved
Summit is available. We apologize for the inconvenience. We will continue to closely monitor.
Posted 6 months ago. May 30, 2018 - 14:10 EDT
Investigating
Summit is intermittently unavailable. We are actively working this issue and will provide an update when the issue is resolved.
Posted 6 months ago. May 29, 2018 - 17:19 EDT
This incident affected: Summit (Summit - Finance, Summit - HR, Summit - Student).