Summit Hr - Batch Running Late
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted about 1 month ago. Dec 12, 2018 - 16:04 EST
Investigating
Summit HR and Position Management are running late due to HR PeopleSoft running long.
Posted about 1 month ago. Dec 12, 2018 - 07:57 EST
This incident affected: Summit (Summit - HR).