Office 365 Degraded Performance
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted 3 months ago. Oct 23, 2018 - 10:19 EDT
Monitoring
Performance impacted. Actively working as an issue. Users may experience intermittent delays or navigation errors when accessing SharePoint sites or OneDrive content.
Posted 3 months ago. Oct 22, 2018 - 10:54 EDT
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).