Student Services Parent Major Outage
Incident Report for UMass Shared Services
Resolved
Student Service Parent access is available. We apologize for the inconvenience.
Posted 20 days ago. Apr 03, 2019 - 11:07 EDT
Identified
Student Services Parent Access is currently unavailable. We are actively working to restore Parent access. We apologize for the inconvenience.
Posted 20 days ago. Apr 03, 2019 - 09:03 EDT
This incident affected: Student Services (Parent Access).