HR Direct - Outage
Incident Report for UMass Shared Services
Resolved
The issue with HR Direct is resolved. We apologize for the inconvenience.
Posted 10 months ago. Oct 20, 2017 - 11:21 EDT
Investigating
HR Direct is currently unavailable. Actively working as an issue.
Posted 10 months ago. Oct 20, 2017 - 10:33 EDT
This incident affected: HR Direct.