Office 365 Degraded Performance
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted 17 days ago. Oct 29, 2018 - 13:12 EDT
Investigating
Performance impacted. Actively working as an issue. Users may experience intermittent delays or navigation errors when accessing SharePoint sites or OneDrive content. A ticket has been opened with Microsoft.
Posted 17 days ago. Oct 29, 2018 - 10:58 EDT
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).