Multiple Applications Major Outage
Incident Report for UMass Shared Services
Resolved
A change was made at 12:30pm on Thursday, May 23rd to fully resolve the intermittent service disruptions and degraded performance. As a result, we continue to observe normal performance and stability of the services. We will continue to monitor services closely.

Our apologies for the disruption to services this week, particularly on Monday. We assure you that we will perform a thorough investigation of this issue to fully understand root cause and to make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 3 months ago. May 23, 2019 - 14:38 EDT
Monitoring
Our campus partners have reported and we have observed service stability and a return to normal performance of services throughout the day today. We are still not ready to declare the issue resolved as we continue to investigate several potential causes for the prior service interruptions. We remain engaged with vendors and campuses to troubleshoot and perform periodic health checks. We will continue to closely monitor services and remain in an all-hands approach to determine the cause.
Posted 3 months ago. May 22, 2019 - 17:04 EDT
Update
While we saw improvements to service stability and performance today compared with Monday, we are not ready to declare the issue resolved. We continue to investigate several potential causes externally and internally and are working with vendors and campuses to troubleshoot and perform comprehensive scans and health checks. We have implemented a small number of changes to improve service and will be implementing additional changes throughout the night. We apologize for the continued service disruption and are taking an all-hands approach to restore service as soon as possible.
Posted 3 months ago. May 21, 2019 - 16:35 EDT
Update
Services are still experiencing intermittent disruptions and degraded performance. Since yesterday, we have seen a significant increase in connectivity to our systems. We are actively working with vendors and campuses with the highest priority to determine the root cause and to mitigate the impact. We apologize for the continued disruption while we work to restore service.
Posted 3 months ago. May 21, 2019 - 11:28 EDT
Investigating
Users are experiencing severe slowness when accessing or navigating in multiple applications, including Student Systems (Boston, Dartmouth, Lowell), HR Direct, Summit, and Finance. We are working to resolve this as quickly as possible.
Posted 3 months ago. May 21, 2019 - 09:51 EDT
This incident affected: Summit (* Summit - Finance, * Summit - HR, * Summit - Student, * Summit - Executive, * Summit - Tableau), Student Services (* Student Production (Boston, Dartmouth, Lowell)), Human Resources (* HR Direct), and Finance Systems (* Finance Production).