Office 365 - Degraded Performance
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 15, 2019 - 17:29 EST
Investigating
Performance impacted. Actively working as an issue.
Posted 2 months ago. Feb 14, 2019 - 14:21 EST
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).