Summit Student - Partial Outage
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted 4 months ago. Jun 18, 2019 - 08:55 EDT
Monitoring
Summit Student is running late. The estimated completion time is 8:30 to 9:00 am.
Posted 4 months ago. Jun 18, 2019 - 07:18 EDT
This incident affected: Summit (* Summit - Student).