Summit Position Management Batch Running Late
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted 11 days ago. Oct 05, 2018 - 11:56 EDT
Monitoring
Batch is running late. Estimated completion is 11:30 AM.
Posted 11 days ago. Oct 05, 2018 - 11:05 EDT