Student Services - Major Outage
Incident Report for UMass Shared Services
Resolved
Access to Student Services has been fully restored. We will continue to closely monitor. We apologize for any inconvenience.
Posted Apr 21, 2020 - 08:43 EDT
Investigating
Multiple Student Services are unavailable. We are urgently investigating with multiple teams. We will send an update as soon as possible. We apologize for any inconvenience.
Posted Apr 21, 2020 - 08:08 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, * eTranscript, Parent Access, ID Email Lookup, myUMB Applicant Portal).