Finance Systems Operational
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted 8 months ago. Dec 14, 2016 - 09:48 EST
Investigating
System currently unavailable. Actively working as an issue.
Posted 8 months ago. Dec 14, 2016 - 09:25 EST
This incident affected: Finance Systems (Effort Certification).