HR Direct - Partial Outage
Incident Report for UMass Shared Services
Resolved
The issue with HR Direct is resolved.
Posted 7 months ago. May 04, 2018 - 16:49 EDT
Monitoring
HR Direct will be experiencing login and performance issues on and off all day. Our technical staff will clear issues as soon as they show up on monitoring services.
Posted 7 months ago. May 04, 2018 - 11:01 EDT