Parent Access Major Outage
Incident Report for UMass Shared Services
Resolved
Parent Access has been resumed.
Posted 12 days ago. Nov 28, 2018 - 18:44 EST
Investigating
Parent/UShare/Designated Access. Can log in, but not presented with the screens as expected. Cannot access the information they have been granted access to.
Posted 13 days ago. Nov 27, 2018 - 13:16 EST
This incident affected: Student Services (Parent Access).