Service Interruption – Microsoft Exchange Email
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted 24 days ago. Nov 16, 2018 - 14:25 EST
Investigating
Investigating: We are experiencing email delivery delays at this time. This is being investigated
Posted 24 days ago. Nov 16, 2018 - 13:57 EST
This incident affected: UMSO Collaboration and Communication Tools (UMSO Email, UMSO Outlook Web Access).