Student Production (Boston, Dartmouth, Lowell) Major Outage
Incident Report for UMass Shared Services
Resolved
The Student Production (Boston, Dartmouth, Lowell) system is available as of approximately 11:45 a.m. We will continue to closely monitor. We apologize for the inconvenience.
Posted Nov 30, 2021 - 11:49 EST
Investigating
We are urgently investigating issues logging into and navigating the Student Production (Boston, Dartmouth, Lowell) systems.
Posted Nov 30, 2021 - 10:58 EST
This incident affected: Student Services (*Student Production (Boston, Dartmouth, Lowell)).