Effort Certification - Outage
Incident Report for UMass Shared Services
Resolved
Issues regarding Effort Certification have been resolved.
Posted Nov 29, 2022 - 11:42 EST
Investigating
Effort Certification is currently unavailable. We are urgently investigating the issue and working to restore service. We apologize for the inconvenience.
Posted Nov 29, 2022 - 11:18 EST
This incident affected: Finance Systems (* Effort Certification).