Multiple Apps - Degraded Performance
Incident Report for UMass Shared Services
Resolved
UMass Dartmouth access to Student Services and HR Direct has been stable since the initial incident report on Monday, 4/20/20.
Posted Apr 26, 2020 - 03:48 EDT
Investigating
Multiple UITS and UMass Dartmouth teams are actively investigating reports from UMass Dartmouth customers of intermittent issues logging into and navigating the Student Production and HR systems. An update will be provided as soon as we know more. We apologize for any inconvenience.
Posted Apr 20, 2020 - 14:14 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell)) and Human Resources (* HR Direct).