Student Services - Major Outage
Incident Report for UMass Shared Services
Resolved
Access to Student Services has been fully restored, including Student Production (Boston, Dartmouth, Lowell), Check Status, Parent, UMass Custom Application, and ID Email Lookup. We will continue to closely monitor. We apologize for the service disruption.
Posted 4 months ago. Jun 25, 2019 - 07:21 EDT
Investigating
Many student services are currently unavailable, including Student Production (Boston, Dartmouth, Lowell), Check Status, Parent, UMass Custom Application, and ID Email Lookup. We are actively investigating. We apologize for the service disruption.
Posted 4 months ago. Jun 25, 2019 - 06:40 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, Parent Access, ID Email Lookup).