HR Direct - Degraded Performance
Incident Report for UMass Shared Services
Resolved
Employee Self Service Weekly Time Entry in HR Direct is fully available.
Posted 3 months ago. Jul 26, 2019 - 15:10 EDT
Monitoring
Employee Self Service Weekly Time Entry in HR Direct may be unavailable due to system updates that are in progress. We expect Employee Self Service Weekly Time Entry in HR Direct to be fully available by 4:00 p.m. today. We apologize for any service disruption.
Posted 3 months ago. Jul 26, 2019 - 14:36 EDT
This incident affected: Human Resources (* HR Direct).