Batch running late
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted Aug 24, 2020 - 08:14 EDT
Monitoring
Batch running late.
Will have an update at 08:30am
Posted Aug 24, 2020 - 06:40 EDT
This incident affected: Summit (* Summit - Student).