SA Tools Upgrade
Scheduled for Jul 20, 17:00 EDT  -  Jul 22, 15:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted 10 days ago. Jul 09, 2018 - 16:24 EDT
Scheduled
SA BDL PeopleTools and Bundle 49 Upgrade
Posted 10 days ago. Jul 09, 2018 - 16:20 EDT
This scheduled maintenance affects: Student Services (Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, eTranscript, Parent Access).