myUMB Applicant Portal - Partial Outage
Incident Report for UMass Shared Services
Resolved
The myUMB Applicant Portal is available. We apologize for the service interruption.
Posted 13 days ago. Oct 09, 2019 - 13:04 EDT
Investigating
Some UMB users are getting an error accessing the applicant portal.. Actively working as an issue.
Posted 13 days ago. Oct 09, 2019 - 12:21 EDT
This incident affected: Student Services (myUMB Applicant Portal).