Finance Production - Major Outage
Incident Report for UMass Shared Services
Resolved
Access to the Finance application has been restored and all pages are accessible. We apologize for the service disruption.
Posted 11 days ago. Sep 06, 2019 - 09:16 EDT
Update
We are continuing to investigate this issue.
Posted 11 days ago. Sep 06, 2019 - 08:52 EDT
Investigating
The Finance production application is unavailable. We are actively investigating. We apologize for the service disruption.
Posted 11 days ago. Sep 06, 2019 - 08:23 EDT
This incident affected: Finance Systems (* Finance Production).