Microsoft Exchange Email - Major Outage
Incident Report for UMass Shared Services
Resolved
The Exchange email connectivity issues are resolved. Please restart Outlook or reboot your machine if connectivity issues persist.
Posted 5 days ago. Apr 17, 2019 - 15:57 EDT
Update
We are continuing to investigate this issue.
Posted 6 days ago. Apr 17, 2019 - 14:47 EDT
Investigating
We have received multiple reports of connectivity issues to Exchange email, including Outlook webmail. We will send an update when resolved.
Posted 6 days ago. Apr 17, 2019 - 14:47 EDT
This incident affected: UMSO Collaboration and Communication Tools (UMSO Email).