Umassp_Prod Is Down
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 27, 2017 - 07:20 EDT
Investigating
Umassp.Edu homepage is presently down. IT is aware and is presently investigating the issue. Thank-you for your patience
Posted 3 months ago. Sep 27, 2017 - 06:25 EDT
This incident affected: Web Services (UMassp.edu).