Student Services - Degraded Performance
Incident Report for UMass Shared Services
Resolved
Access to Student Services has been fully restored as of 6:00 p.m. We will continue to closely monitor to assure stability of the Student Services. We apologize for any inconvenience.
Posted Apr 21, 2020 - 18:51 EDT
Investigating
Multiple Student Services are intermittently unavailable or experiencing slow performance. We are urgently investigating the issue with multiple teams. We will send an update as soon as possible. We apologize for any inconvenience.
Posted Apr 21, 2020 - 12:52 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell), Admissions - UMass Custom Application, Admissions - Check Status, * eTranscript, Parent Access, ID Email Lookup, myUMB Applicant Portal).