Office 365 (SharePoint) - Degraded Performance
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted Nov 22, 2019 - 08:14 EST
Investigating
Performance impacted. Actively working as an issue.
Posted Nov 21, 2019 - 15:04 EST
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).