Document Imaging Major Outage
Incident Report for UMass Shared Services
Resolved
Document Imaging (Boston, Dartmouth, Lowell) is available. We will closely monitor and continue to troubleshoot why this event occurred. We apologize for the inconvenience.
Posted Jan 22, 2021 - 10:26 EST
Investigating
Document Imaging (Boston, Dartmouth, Lowell) is unavailable. We are actively working as an issue.
Posted Jan 22, 2021 - 08:49 EST
This incident affected: * Document Imaging (Boston, Dartmouth, Lowell).