Student Services Partial Outage
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 27, 2018 - 08:53 EST
Investigating
Partial outage. Actively working as an issue.
Some applicants with multiple applications to Boston and Dartmouth or Boston and Lowell could be having an issue logging into one of the two areas.
Posted 24 days ago. Nov 16, 2018 - 15:24 EST
This incident affected: Student Services (Admissions - Check Status).