Office 365 - Degraded Performance
Incident Report for UMass Shared Services
Resolved
Service now available. Microsoft has resolved intermittent delays with OneDrive and SharePoint content.
Posted about 1 month ago. Mar 11, 2019 - 12:17 EDT
Monitoring
We are continuing to monitor issues with OneDrive and SharePoint on Office 365.
Posted about 1 month ago. Mar 11, 2019 - 11:14 EDT
Investigating
Performance impacted. Actively working as an issue.
Posted about 2 months ago. Mar 08, 2019 - 14:18 EST
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).