Office 365 - Degraded Performance
Incident Report for UMass Shared Services
Resolved
The issue is resolved.
Posted about 1 year ago. Aug 08, 2016 - 06:41 EDT
Monitoring
Performance impacted. Actively working as an issue.

Impacted: Office of the President SharePoint Online Sites

Impact: Users may receive errors when uploading or accessing documents. This issue is sporadic and may impact some document libraries while others will be fine. Microsoft is currently working this as a critical issue.
Posted about 1 year ago. Aug 05, 2016 - 10:50 EDT