Multiple Applications Unavailable for Lowell
Incident Report for UMass Shared Services
Resolved
Application access has been restored for Lowell users. We will continue to closely monitor. We apologize for any inconvenience.
Posted 9 months ago. Nov 28, 2018 - 23:38 EST
Investigating
Multiple applications are unavailable for Lowell users. We are actively investigating the issue.
Posted 9 months ago. Nov 28, 2018 - 20:34 EST
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell)), Human Resources (* HR Direct), and Summit (* Summit - Student).