Summit HR - Partial Outage
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted about 1 year ago. Dec 08, 2017 - 11:33 EST
Investigating
Partial outage. Actively working as an issue. Summit HR is unavailable. Estimated time of resolution: 11:45 AM.
Posted about 1 year ago. Dec 08, 2017 - 10:21 EST
This incident affected: Summit (Summit - HR).