Office 365 (SharePoint) - Major Outage
Incident Report for UMass Shared Services
Resolved
SharePoint sites are now available.
Posted Oct 05, 2019 - 08:53 EDT
Investigating
SharePoint sites are currently unavailable. Actively working the issue.
Posted Oct 04, 2019 - 16:14 EDT
This incident affected: UMSO Collaboration and Communication Tools (Office 365 (SharePoint)).