massachusetts.edu - Major Outage

Incident Report for UMass Shared Services

Resolved

massachusetts.edu is now responding normally.
Posted Feb 03, 2026 - 14:58 EST

Investigating

massachusetts.edu is currently unavailable. We are working to restore service as soon as possible. Thank you for your patience.
Posted Feb 03, 2026 - 14:23 EST
This incident affected: Web Services (Massachusetts.edu).