HR Direct - Degraded Performance
Incident Report for UMass Shared Services
Resolved
All transactions have posted successfully in HR Direct. We apologize for the inconvenience. We will continue to closely monitor.
Posted Dec 09, 2019 - 16:29 EST
Identified
There are delays in posting some transactions into the HR Direct system. The reports that are used by time keepers are unavailable. We are working on clearing up the transactions and will provide you an update as soon as possible.
Posted Dec 09, 2019 - 10:31 EST
This incident affected: Human Resources (* HR Direct).