UMSO Email - Degraded Performance

Incident Report for UMass Shared Services

Resolved

Microsoft has resolved the infrastructure issues that impacted a large number of North American Clients, including UMSO email. Email queues have been cleared and email is functioning as expected.
Posted Jan 23, 2026 - 10:11 EST

Monitoring

We are currently experiencing delays in receiving email from external senders due to a Microsoft service issue that began around 4:00 p.m. and is impacting many customers across North America.

Microsoft has since rectified the infrastructure failure that caused this incident, but they are still working to release the large backlog of email that remains in queue
Posted Jan 22, 2026 - 21:45 EST
This incident affected: UMSO Communication and Collaboration Tools (UMSO Email).