Document Imaging (Boston, Dartmouth, Lowell) Major Outage
Incident Report for UMass Shared Services
Resolved
Document Imaging (Boston, Dartmouth, Lowell) is available. We apologize for the inconvenience.
Posted Mar 15, 2021 - 08:27 EDT
Investigating
Document Imaging (Boston, Dartmouth, Lowell) is currently unavailable. We are urgently working to restore service.
Posted Mar 15, 2021 - 07:34 EDT
This incident affected: * Document Imaging (Boston, Dartmouth, Lowell).