Document Imaging - Major Outage

Incident Report for UMass Shared Services

Resolved

Document Imaging is now up and accessible.
Posted Oct 28, 2025 - 11:53 EDT

Investigating

Document Imaging is currently unavailable. Thank you for your patience while we work to restore service.
Posted Oct 28, 2025 - 10:50 EDT
This incident affected: * Document Imaging (Boston, Dartmouth, Lowell).