Document Imaging (Boston, Dartmouth, Lowell) performance issue

Incident Report for UMass Shared Services

Resolved

Resolved – The vendor has deployed a fix during the 10pm window last night.
Posted Jul 31, 2026 - 08:56 EDT

Monitoring

Softdocs has prepared a fix and will deploy it tonight, July 30, between 10:00 and 11:00 p.m. ET.

Etrieve Content is expected to be unavailable for approximately 10 minutes during the deployment window.

We appreciate your patience while Softdocs works to resolve this issue.
Posted Jul 30, 2026 - 17:52 EDT

Investigating

Researching potential issue.

Degraded Performance – Search (New Content), Retention, and Collaboration services.

The vendor Softdocs, is actively investigating the issue and working toward a resolution. UITS is monitoring the situation and will provide updates as additional information becomes available.
Posted Jul 30, 2026 - 11:44 EDT
This incident affected: * Document Imaging (Boston, Dartmouth, Lowell).