Salesforce - issues creating and editing cases

Incident Report for UMass Shared Services

Resolved

UITS has verified that SalesForce functionality has been fully restored
Posted Mar 10, 2025 - 13:58 EDT

Update

As of 10:00 PM on Sunday, 03/09/25, the problem editing existing cases has not been resolved. UITS is actively working with the vendor to resolve the problem as soon as possible.
Posted Mar 09, 2025 - 21:58 EDT

Investigating

Problems have been encountered creating and editing cases in Salesforce

Cases can now be created but cannot be saved when edited or updated after creation

Emails can still be sent to and from the case after creation

UITS support is currently investigating with Salesforce support
Posted Mar 09, 2025 - 13:09 EDT
This incident affected: UMSO Operational and Project Services (* UMPO Salesforce).