Degraded Performance - Multiple Applications

Incident Report for UMass Shared Services

Resolved

Please note that the roll-back was successful and performance has been restored. Thank you for your patience.
Posted Jun 12, 2026 - 11:29 EDT

Identified

We are currently working to roll-back a change implemented this morning that is negatively affecting performance across multiple applications. Thank you for your patience.
Posted Jun 12, 2026 - 09:38 EDT
This incident affected: Human Resources (* HR Direct), Student Services (*Student Production (Boston, Dartmouth, Lowell), Admissions - Check Status), and Finance Systems (* Finance Production).