Umassp.edu - Partial Outage

Incident Report for UMass Shared Services

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 09:02 EDT

Monitoring

Umassp.edu is now responding normally. We will continue to monitor performance.
Posted Aug 27, 2025 - 15:32 EDT

Identified

umassp.edu is experiencing a partial outage. We are aware of this issue and are actively working with our hosting provider to fix the performance issues and restore service.
Posted Aug 27, 2025 - 14:56 EDT
This incident affected: Web Services (UMassp.edu).